WordPress — Ошибка при переходе с PHP 5.6 на РHP 7.3 (Решено)

Уведомление wordpress о необходимости перехода на свежую версию PHP

После перевода php 5.6 => 7.3.0 через панель хостинга, WordPress выдал ошибку, при этом старый пароль был верным:

Ошибка установки соединения с базой данных
Это значит, что либо имя пользователя и пароль в файле wp-config.php неверны, либо нам не удалось связаться с сервером базы данных по адресу localhost. Возможно, сервер недоступен.
Вы уверены, что указали правильное имя пользователя и пароль?
Вы уверены, что ввели правильное имя сервера?
Вы уверены, что сервер базы данных запущен?
Если вы не знаете, что означают эти термины — возможно, стоит обратиться к хостинг-провайдеру. Если и после этого вам понадобится помощь — всегда можно посетить форум поддержки WordPress.

В моём случае помогла смена пароля MySql на новый более сложный,

  • Сгенерировать новый пароль MySql для базы данных
  • Заменить пароль в файле конфигурации — wp-config.php

Leave a Reply

  

  

  

Этот сайт использует Akismet для борьбы со спамом. Узнайте как обрабатываются ваши данные комментариев.